Issues with passing values to environment variables

Incident Report for Bitrise

Resolved

This incident is now resolved and impacted services are now operating without issues.

Our teams identified the root cause, released a fix and were monitoring our systems continuously to ensure the mitigation is safe. We'll conduct an internal post-mortem to understand what happened and learn how to avoid a similar outage in the future.

Thank you for your patience and understanding. If you encounter any issues, please reach out to our Support team:

https://support.bitrise.io/en/
Posted Dec 03, 2025 - 10:59 UTC

Identified

We are currently investigating an incident that is causing issues with passing values to environment variables. The team is working on a fix.

Services:
Environment Variables

Scope:
All users

Severity:
SEV-2

What we’re doing?

Our Engineering teams are actively investigating this issue. We are working on immediate actions to remediate this issue.

When will the next update be available?

You can expect a status update approximately 1 hour from now.
Posted Dec 03, 2025 - 10:18 UTC
This incident affected: ⚙️ Builds (CI).